注册 登录
查看: 700|回复: 8

有没有试过用Jlink调试程序ok,重新上电,程序运行不了

[复制链接]
发表于 2013-5-7 11:23:43 | 显示全部楼层 |阅读模式
各位 ,,有没有遇到这种问题:

jlink调试程序,程序正常运行,

断开jlink重新上电,程序没有运行。。

调试时是按"DownLoad and Debug"的

工程的option设置页没有错。。

这是哪里出现问题???
回复

使用道具 举报

发表于 2013-5-7 11:35:20 | 显示全部楼层
程序是怎么烧写的呢?求助http://www.vcan123.com/forum.php?mod=viewthread&tid=78
回复 支持 反对

使用道具 举报

发表于 2013-5-7 11:36:01 | 显示全部楼层
我是小白,看的那个三天入门的PDF遇到了几个问题
1烧写程序到芯片的时候,用IAR就可以,还是必须用J-FLASH,其中烧写的步骤是什么,使用J-FLASH打开HEX文件吗?其中如何配置?
2我的JLINK没接芯片的时候灯是绿色的,接上K60后就成红色了,这现象对吗?正常情况应该是什么样子的?
回复 支持 反对

使用道具 举报

发表于 2013-5-7 11:36:58 | 显示全部楼层
你好,在工程选项里设置一下:
Debugger —— Download 下 勾上 Use flash loader






本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复 支持 反对

使用道具 举报

发表于 2013-5-7 11:40:48 | 显示全部楼层
sjl123 发表于 2013-5-7 11:36
我是小白,看的那个三天入门的PDF遇到了几个问题
1烧写程序到芯片的时候,用IAR就可以,还是必须用J-FLASH ...

K60后就成红色 ,说明 jlink 没法正常连接到 k60 上 ,需要进行解锁

IAR 可以直接烧程序 , j-Flash 也可以烧程序。

j-Flash设置请看此教程(第7页):
http://pan.baidu.com/share/link?shareid=553723&uk=235751603
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-5-7 11:44:13 | 显示全部楼层
山外メ雲ジ 发表于 2013-5-7 11:36
你好,在工程选项里设置一下:
Debugger —— Download 下 勾上 Use flash loader

勾了,,还是不行
回复 支持 反对

使用道具 举报

发表于 2013-5-7 11:52:22 | 显示全部楼层
Admin 发表于 2013-5-7 11:40
K60后就成红色 ,说明 jlink 没法正常连接到 k60 上 ,需要进行解锁

IAR 可以直接烧程序 , j-Flash 也 ...

非常感谢,解锁有这个提示

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复 支持 反对

使用道具 举报

发表于 2013-5-7 18:01:12 来自手机 | 显示全部楼层
是否下载程序到ram里了?
回复 支持 反对

使用道具 举报

发表于 2013-5-8 10:42:30 | 显示全部楼层
sjl123 发表于 2013-5-7 11:52
非常感谢,解锁有这个提示

芯片是不是自己焊接的?如果自己焊接,一般都是焊接不好导致的
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部