注册 登录
查看: 830|回复: 6

[摄像头组] 上位机调试

[复制链接]
发表于 2015-1-29 01:08:23 | 显示全部楼层 |阅读模式
不好意思,因为某些原因传不了图,但是还是希望得到大家帮助,所以只能口头描述了。
我用的山外参考例程 LCD_摄像头
  • /*
  • * 定义 printf函数 的 串口输出端口 和 串口信息
  • */
  • #define VCAN_PORT UART4
  • #define VCAN_BAUD 115200


普通浏览复制代码保存代码打印代码
  • /*
  • * 定义 printf函数 的 串口输出端口 和 串口信息
  • */
  • #define VCAN_PORT UART4
  • #define VCAN_BAUD 115200



/*<br /> * 定义 printf函数 的 串口输出端口 和 串口信息<br /> */<br />#define VCAN_PORT           UART4<br />#define VCAN_BAUD           115200<br />

因为用了mini cap,所以找不到原先的UART3的管脚了,发现核心板上的蓝牙排座上有UART4的管脚,于是将上面的UART3改成UART4.
但是无论是yy串口助手还是多功能串口助手均没有反应。
  • while(1)
  • {
  • camera_get_img(); //摄像头获取图像
  • //黑白摄像头
  • LCD_Img_Binary_Z(site, size, imgbuff, imgsize);
  • /******************** 发送图像到上位机 ***********************/
  • img_extract(img, imgbuff, CAMERA_SIZE); //解压为灰度图像,方便发送到上位机显
  • sendimg(img, CAMERA_W * CAMERA_H); //发送到上位机
  • }

普通浏览复制代码保存代码打印代码
  • while(1)
  • {
  • camera_get_img(); //摄像头获取图像
  • //黑白摄像头
  • LCD_Img_Binary_Z(site, size, imgbuff, imgsize);

  • /******************** 发送图像到上位机 ***********************/
  • img_extract(img, imgbuff, CAMERA_SIZE); //解压为灰度图像,方便发送到上位机显
  • sendimg(img, CAMERA_W * CAMERA_H); //发送到上位机
  • }


while(1)<br />    {<br />        camera_get_img();                                   //摄像头获取图像<br />                      //黑白摄像头<br />        LCD_Img_Binary_Z(site, size, imgbuff, imgsize);<br /><br />        /******************** 发送图像到上位机 ***********************/<br />        img_extract(img, imgbuff, CAMERA_SIZE);          //解压为灰度图像,方便发送到上位机显<br />        sendimg(img, CAMERA_W * CAMERA_H);                    //发送到上位机<br />    }

我以为可能串口没信号,但是我打开串口助手:发现收到UART传送成功字样Get ID success,SENSOR ID is 0x21
Config Register Number is 49
OV7725 Register Config Success!�������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������
如以上所示,传出的不是数字,
这是怎么回事,是哪里出了问题。应该与FT232无关。因为能成功printf内容

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复

使用道具 举报

发表于 2015-1-29 01:32:30 | 显示全部楼层
你的代码是YY上位机,而不是多功能上位机。5.2版本有多功能上位机的例程。
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-1-29 01:35:38 | 显示全部楼层
可是我有用过yy上位机,没反应
来自PC客户端 来自PC客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-1-29 01:36:02 | 显示全部楼层
刚刚改过了,多功能调试器可以了,但是yy的不行
来自PC客户端 来自PC客户端
回复 支持 反对

使用道具 举报

发表于 2015-1-31 19:13:27 | 显示全部楼层
请问你用的是什么串口啊
回复 支持 反对

使用道具 举报

发表于 2015-1-31 20:29:00 | 显示全部楼层
779675229 发表于 2015-1-29 01:36
刚刚改过了,多功能调试器可以了,但是yy的不行

可能你没设置上位机的配置。
回复 支持 反对

使用道具 举报

发表于 2015-12-12 15:55:03 | 显示全部楼层
楼主,问题解决了吗?同求
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部