注册 登录
查看: 392|回复: 7

直立程序问题 山外哥求帮忙

[复制链接]
发表于 2015-1-3 15:38:29 | 显示全部楼层 |阅读模式
山外哥  为什么我用野火站立平衡组中级篇调直立  没法实现呢  每次只能转一个轮子 而且是朝一个方向转的啊 (引脚什么的都是对应上的)
  我传了  我修改后的程序 不知道问题出在哪里了 求帮忙

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复

使用道具 举报

发表于 2015-1-3 15:39:20 | 显示全部楼层
这个得你自己调一下,首先检查电机转动问题。

需要排除法找问题,其他人没法帮忙解决的。
来自PC客户端 来自PC客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-1-3 15:39:31 | 显示全部楼层
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-1-3 16:03:56 | 显示全部楼层
不行啊  我单用电机驱动程序 轮子是转的 没问题的  但是 我调直立时 陀螺仪融合后 加p参数后 只有一个轮子转 吵一个方向转 也就是只有ch0有输出 其他的电机3个输出口没输出  我也直接用示波器测过单片机输出 只有一个ch0(c1)有输出 其他的没有输出  山外哥 你说这是不是程序的问题啊

回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-1-3 16:04:24 | 显示全部楼层
山外メ雲ジ 发表于 2015-1-3 15:39
这个得你自己调一下,首先检查电机转动问题。

需要排除法找问题,其他人没法帮忙解决的。

不行啊 我单用电机驱动程序 轮子是转的 没问题的 但是 我调直立时 陀螺仪融合后 加p参数后 只有一个轮子转 吵一个方向转 也就是只有ch0有输出 其他的电机3个输出口没输出 我也直接用示波器测过单片机输出 只有一个ch0(c1)有输出 其他的没有输出 山外哥 你说这是不是程序的问题啊
回复 支持 反对

使用道具 举报

发表于 2015-1-3 16:05:18 | 显示全部楼层
我我我 发表于 1420272236
不行啊  我单用电机驱动程序 轮子是转的 没问题的  但是 我调直立时 陀螺仪融合后 加p参数后 只有一个轮子转 吵一个方向转 也就是只有ch0有输出 其他的电机3个输出口没输出  我也直接用示波器测过单片机输出 只有一个ch0(c1)有输出 其他的没有输出  山外哥 你说这是不是程序的问题啊
这样子的话,就是电机驱动那部分的代码配置有问题,你调一下,看看跟你的硬件接线是否匹配吧。

这东西,不调试,我也不知道对比对的。
来自PC客户端 来自PC客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-1-3 16:17:46 | 显示全部楼层
山外メ雲ジ 发表于 2015-1-3 16:05
这样子的话,就是电机驱动那部分的代码配置有问题,你调一下,看看跟你的硬件接线是否匹配吧。

这东西, ...

还是 谢谢了 其实这些问题 应该排除了 我都考虑了3天了 我想问你的那个新库没问题吧  我总感觉程序的问题
回复 支持 反对

使用道具 举报

发表于 2015-1-4 10:46:05 | 显示全部楼层
我我我 发表于 2015-1-3 16:17
还是 谢谢了 其实这些问题 应该排除了 我都考虑了3天了 我想问你的那个新库没问题吧  我总感觉程序的问题

没问题啊!
出来就开始用了!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部