注册 登录
查看: 556|回复: 9

[平衡组] 求用山外中级篇调好直立的冒个泡 谢谢

[复制链接]
发表于 2014-12-21 09:41:22 | 显示全部楼层 |阅读模式
我遇到一个很怪怪的问题,就是在调融合角度和Z轴的跟踪问题的时候,,,,,我的那个参数Gyro_ratio 只有在0.049的时候才能比较好的跟踪。。。。。。请问这样可以吗我看山外哥的那个都0.8.。。



回复

使用道具 举报

发表于 2014-12-21 11:27:33 | 显示全部楼层
不同的陀螺仪,参数是不同的。

你上传一下波形看看效果
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-21 14:53:16 | 显示全部楼层
法平心 发表于 2014-12-21 11:27
不同的陀螺仪,参数是不同的。

你上传一下波形看看效果

谢谢哈~~~ 改了一下系数 波形

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复 支持 反对

使用道具 举报

发表于 2014-12-21 15:06:06 | 显示全部楼层
紫色是融合后的?

感觉有点抖动啊。陀螺仪信号呢?没看到
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-21 15:26:38 | 显示全部楼层
严群 发表于 2014-12-21 15:06
紫色是融合后的?

感觉有点抖动啊。陀螺仪信号呢?没看到

陀螺仪被窝屏蔽了,,,太多线看的晕。。。嗯是有点抖动,,,陀螺仪的也是。也会抖,请问是什么原因,,信号线太长吗?我的信号线还真挺长的30厘米到25厘米的样子
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-21 15:30:44 | 显示全部楼层
严群 发表于 2014-12-21 15:06
紫色是融合后的?

感觉有点抖动啊。陀螺仪信号呢?没看到

今天中午我有想试试让车直立,但是不知道是机械机构不行还是什么原因,,往后走的时候可以站住,,,但是往前面走的时候战不住,,,,没有重力那么猛
回复 支持 反对

使用道具 举报

发表于 2014-12-23 09:22:50 | 显示全部楼层
你们进展的挺快啊,本人菜鸟,初级篇还没搞懂,求指导,可否留QQ交流
回复 支持 反对

使用道具 举报

发表于 2015-1-17 21:28:04 | 显示全部楼层
彭意达 发表于 2014-12-21 15:26
陀螺仪被窝屏蔽了,,,太多线看的晕。。。嗯是有点抖动,,,陀螺仪的也是。也会抖,请问是什么原因,, ...

信号线对调试影响很大么?我当时为了调试方便,信号线很长,30cm左右,结果一直觉着信号采集的比较慢,5ms采集一次的话,应该不算很慢吧,但是在调车的时候,手扶着车子倾斜,在离中心点偏差很小的时候,电机不转!大概2~3秒才会有反应,看了程序中PWM赋值这一块,没有错误,而且保证中断是正常的,那么这2~3s的时间为什么电机不转呢?
回复 支持 反对

使用道具 举报

发表于 2015-1-23 12:16:32 | 显示全部楼层
法平心 发表于 2014-12-21 11:27
不同的陀螺仪,参数是不同的。

你上传一下波形看看效果

赞!@
回复 支持 反对

使用道具 举报

发表于 2015-2-6 19:27:10 | 显示全部楼层
彭意达 发表于 2014-12-21 14:53
谢谢哈~~~ 改了一下系数 波形

这个波形不是超调了么?
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部