注册 登录
查看: 462|回复: 14

[鹰眼] 用的V5.1的例程,上位机没有反应

[复制链接]
发表于 2014-12-18 10:53:06 | 显示全部楼层 |阅读模式
用的是V5.1里的“DMA_鹰眼摄像头OV7725串口显示”代码。鹰眼摄像头,插在核心板+小底板上,
试过了YY助手,和多功能串口调试助手(同时复制了山外哥那个贴的代码),都毫无反应。
摄像头后面的蓝灯是亮的。设置的是80*60像素,115200波特率,和视频上一样。
帮忙看看是什么问题。
回复

使用道具 举报

发表于 2014-12-18 11:24:14 | 显示全部楼层
在线调试,看看代码有没有卡死
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-18 11:33:32 | 显示全部楼层
本帖最后由 binary01 于 2014-12-18 11:37 编辑

没有卡住的地方。野火串口调试助手在我电脑上,接受区显示的是黑屏的。会不会是没有办法接收到数据。前几天做串口实验的时候,
第一次打开程序,点了一下发送,接受区就黑了,赶时间就没看。。现在没法测试能不能接收到数据,点了发送后清空,确实清空了。用了别的串口助手也试了一下,都是能发送数据不能接受数据。。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复 支持 反对

使用道具 举报

发表于 2014-12-18 11:48:52 | 显示全部楼层
binary01 发表于 2014-12-18 11:33
没有卡住的地方。野火串口调试助手在我电脑上,接受区显示的是黑屏的。会不会是没有办法接收到数据。前几天 ...

你检查下串口通信是否正常。
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

发表于 2014-12-18 12:04:37 | 显示全部楼层
binary01 发表于 1418873612
没有卡住的地方。野火串口调试助手在我电脑上,接受区显示的是黑屏的。会不会是没有办法接收到数据。前几天做串口实验的时候,
第一次打开程序,点了一下发送,接受区就黑了,赶时间就没看。。现在没法测试能不能接收到数据,点了发送后清空,确实清空了。用了别的串口助手也试了一下,都是能发送数据不能接受数据。。
我们那个接收区域,原本就是黑色的。

不能接收数据,你用串口中断接收那个例程看看。
来自PC客户端 来自PC客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-18 12:30:44 | 显示全部楼层
山外哥,我用了UART_LOOP这个例程试了一下。单步调试的时候,每一步去串口点一下发送,发送函数里面这个判断一直是0.

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-18 12:31:51 | 显示全部楼层

这两个都分别注释掉一个,和两个一块用效果都一样

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-18 12:39:53 | 显示全部楼层
请问串口通讯在哪里看呀
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-18 12:42:15 | 显示全部楼层
不太明白串口通信的意思,做流水灯可以写进程序以为没问题呢。。。我想当然了,忏悔。
串口通信在哪里看呀?
回复 支持 反对

使用道具 举报

发表于 2014-12-18 12:46:11 | 显示全部楼层
binary01 发表于 2014-12-18 12:31
这两个都分别注释掉一个,和两个一块用效果都一样

这例程,会接收串口数据,并发送回上位机,建议你看看视频。有视频的。
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-18 12:46:32 | 显示全部楼层
我的设备管理器:
端口(COM和LPT)       不管插不插JLINK+核心板      都显示
蓝牙通信端口(COM7)
是不是不正常的呀?
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-12-18 13:01:44 | 显示全部楼层
微粒子 发表于 2014-12-18 12:46
这例程,会接收串口数据,并发送回上位机,建议你看看视频。有视频的。

是按照视频来的,判断条件总是零,串口没有接收到数据。一会上课去了,晚上回来再调。谢谢
回复 支持 反对

使用道具 举报

发表于 2014-12-18 14:08:47 | 显示全部楼层
binary01 发表于 2014-12-18 13:01
是按照视频来的,判断条件总是零,串口没有接收到数据。一会上课去了,晚上回来再调。谢谢

全速运行的时候,没接到数据吗?检查一下串口模块。
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

发表于 2014-12-26 00:43:37 | 显示全部楼层
我也是一直是零,是怎么回事
回复 支持 反对

使用道具 举报

发表于 2014-12-26 19:38:29 | 显示全部楼层
叨叨琪琪 发表于 2014-12-26 00:43
我也是一直是零,是怎么回事

你的例程是做什么的,为啥是0,你得介绍一下啊。一般出在波特率或者硬件上
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部