注册 登录
查看: 455|回复: 12

急求!!摄像头程序!!停在一个地方!!

[复制链接]
发表于 2014-11-22 21:34:05 | 显示全部楼层 |阅读模式
在线调试一直停在这:

while( !(SYST_CSR & SysTick_CSR_COUNTFLAG_MASK));


求大神解决!!跪求!!
回复

使用道具 举报

 楼主| 发表于 2014-11-22 22:02:53 | 显示全部楼层
串口接收数据为:进入死循环等待。
回复 支持 反对

使用道具 举报

发表于 2014-11-22 22:12:22 | 显示全部楼层
K60 的新版代码开机长按那个独立按键,LED闪烁问题。 - 智能车讨论区 - 山外论坛 http://vcan123.com/forum.php?mod=viewthread&tid=1321&ctid=1

开机检查,擦除flash的代码。可以注释掉的。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-23 16:58:47 | 显示全部楼层
现在下载程序调试一直停在这个地方。实验程序改了就又不行了,用调试看的好像是应为停在延时函数里了。有时是断言失败。前一段时间把舵机和4路MOS程序合在一块停在舵机初始化了。怎么回事,求教大神!!
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-23 20:00:24 | 显示全部楼层
D12350 发表于 2014-11-23 16:58
现在下载程序调试一直停在这个地方。实验程序改了就又不行了,用调试看的好像是应为停在延时函数里了。有时 ...

有没有大神解释一下。
回复 支持 反对

使用道具 举报

发表于 2014-11-23 20:02:53 | 显示全部楼层
D12350 发表于 2014-11-23 16:58
现在下载程序调试一直停在这个地方。实验程序改了就又不行了,用调试看的好像是应为停在延时函数里了。有时 ...

参考iar调试视频,截图一下调用栈。

可能是pwm占空比超过100%
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-23 20:17:51 | 显示全部楼层
山外メ雲ジ 发表于 2014-11-23 20:02
参考iar调试视频,截图一下调用栈。

可能是pwm占空比超过100%

PWM没有超过,FTM1我设置的是1000u的。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-23 20:31:22 | 显示全部楼层
D12350 发表于 2014-11-23 20:17
PWM没有超过,FTM1我设置的是1000u的。

FX核心板上的D1闪烁。

回复 支持 反对

使用道具 举报

发表于 2014-11-23 20:49:59 | 显示全部楼层
D12350 发表于 2014-11-23 20:17
PWM没有超过,FTM1我设置的是1000u的。

在线调试,可以看出是哪个断言触发的!!
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

发表于 2014-11-23 20:51:19 | 显示全部楼层
D12350 发表于 2014-11-23 20:17
PWM没有超过,FTM1我设置的是1000u的。

是不是led没初始化?或者超频过高?
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-23 21:23:27 | 显示全部楼层
山外メ雲ジ 发表于 1416747079
是不是led没初始化?或者超频过高?
PLL150,没有超频。led_turn(LED2);卡在这。
来自PC客户端 来自PC客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-23 21:23:43 | 显示全部楼层
山外メ雲ジ 发表于 1416747079
是不是led没初始化?或者超频过高?
LED初始化了。
来自PC客户端 来自PC客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-23 21:26:44 | 显示全部楼层
山外メ雲ジ 发表于 1416747079
是不是led没初始化?或者超频过高?
把那个注释掉又卡在了下一句 camera_get_img();
来自PC客户端 来自PC客户端
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部