注册 登录
查看: 391|回复: 8

无线调试出问题了~~~

[复制链接]
发表于 2014-11-16 16:11:15 | 显示全部楼层 |阅读模式
这是我发送端的程序,在“发送 空 命令给调试板模块”这里单步执行了几次就不能执行下去了,一直停在“ while( !nrf_tx(sendbuf , nrf_com_size[com] + 2 * COM_LEN)); //发送数据”
求解~~~~





本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复

使用道具 举报

发表于 2014-11-16 16:13:03 | 显示全部楼层
全速运行呢?有可能有的代码是不可以单步调试的。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-16 16:16:42 | 显示全部楼层
sestpqwnkm 发表于 2014-11-16 16:13
全速运行呢?有可能有的代码是不可以单步调试的。

全速运行也不行
回复 支持 反对

使用道具 举报

发表于 2014-11-16 16:18:14 | 显示全部楼层
跳跳 发表于 2014-11-16 16:16
全速运行也不行

有另外一块单片机,烧录了接收的例程运行着吗?

需要有接收端进行接收,才可以发送成功的。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-16 16:24:54 | 显示全部楼层
东阳霁 发表于 2014-11-16 16:18
有另外一块单片机,烧录了接收的例程运行着吗?

需要有接收端进行接收,才可以发送成功的。

都有的啊,我都醉了!!
回复 支持 反对

使用道具 举报

发表于 2014-11-16 17:34:05 | 显示全部楼层
跳跳 发表于 2014-11-16 16:24
都有的啊,我都醉了!!

是我们的原始例程吗?先运行接收端代码。看看接收端初始化有没有成功。
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-11-16 18:14:58 | 显示全部楼层
山外メ雲ジ 发表于 2014-11-16 17:34
是我们的原始例程吗?先运行接收端代码。看看接收端初始化有没有成功。

嗯,就是你们的历程,接收端没问题,能成功。也能实现无线传输。
就是发送端初始化的时候加进这段代码就在这里卡死了!!!

i = 20;                                                                   //需要发送空命令给调试板模块,这样可以清掉接收失败而产生多余数据
while(i--)
{
        nrf_msg_tx(COM_RETRAN, nrf_tvar_buff);  //发送多个 空 命令过去,用于清空 接收端的缓存数据
}

回复 支持 反对

使用道具 举报

发表于 2014-11-16 18:33:00 | 显示全部楼层
跳跳 发表于 2014-11-16 18:14
嗯,就是你们的历程,接收端没问题,能成功。也能实现无线传输。
就是发送端初始化的时候加进这段代码就 ...

你用的是哪个例程?
来自安卓客户端来自安卓客户端
回复 支持 反对

使用道具 举报

发表于 2016-10-30 23:48:03 | 显示全部楼层
跳跳 发表于 2014-11-16 18:14
嗯,就是你们的历程,接收端没问题,能成功。也能实现无线传输。
就是发送端初始化的时候加进这段代码就 ...

我也遇到了,咋整
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部