注册 登录
查看: 543|回复: 9

[摄像头组] 前面一两圈都没问题,为什么有时车子跑着跑着就冲出弯道了?大家有遇到没?

[复制链接]
发表于 2014-7-13 23:52:22 | 显示全部楼层 |阅读模式
调完阈值后发现,车子在过弯的时候,不再有白色跳动,图像很清晰了。可是有时也会跑着跑着就跑出弯道了,这是什么原因?难道是图像处理不过来?速度也不算快啊,而且前面一两圈还跑得好好的。大家有遇到过没?
还有个奇怪的问题,就是有时候车子跑着跑着就自动慢下来了,甚至停了,没有任何征兆,这又是什么原理?有时候在停了一段时间后又莫名其妙地加速起来,这又是什么原理?是程序跑飞了?
回复

使用道具 举报

发表于 2014-7-14 00:59:30 | 显示全部楼层
走过路过,不能错过
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-7-14 09:45:43 | 显示全部楼层
111xian 发表于 2014-7-14 00:59
走过路过,不能错过

你有没有遇到过?怎么解决的?
回复 支持 反对

使用道具 举报

发表于 2014-7-14 09:51:35 | 显示全部楼层
草原上的星星 发表于 2014-7-14 09:45
你有没有遇到过?怎么解决的?

没遇到过,
是不是你们摄像头跑着跑着就歪了,,所以,,,
回复 支持 反对

使用道具 举报

发表于 2014-7-14 17:31:44 | 显示全部楼层
数据处理不够好,就容易出现出界的问题。
如果有条件,可以试下无线发送到调试器,看图像效果。

车子跑着跑着就自动慢下来了,甚至停了,没有任何征兆。这个,不知道程序卡死在哪里。
回复 支持 反对

使用道具 举报

发表于 2014-7-14 19:24:28 | 显示全部楼层
跑多了跑飞应该是温漂吧~
我也遇到了有时候停  有时候快的问题  有人和我说是速度控制参数没调好 现在还在解决中~
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-7-15 10:18:56 | 显示全部楼层
山外メ雲ジ 发表于 2014-7-14 17:31
数据处理不够好,就容易出现出界的问题。
如果有条件,可以试下无线发送到调试器,看图像效果。

嗯,我们有买无线调试器,看着图像很清晰,应该是方向的P加小了
回复 支持 反对

使用道具 举报

发表于 2014-7-17 19:19:13 | 显示全部楼层
草原上的星星 发表于 2014-7-15 10:18
嗯,我们有买无线调试器,看着图像很清晰,应该是方向的P加小了

你们程序无线调试变量,是怎么赋值的,???
是赋值给VAR1,VAR2等??
还是直接赋值给P D I 参数,,,
为什么我们赋值后,再进行调试就会出现各种诡异情况,,(如电机反向1000减去转速,,最后变为10减),,什么情况???
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-7-20 19:30:52 | 显示全部楼层
111xian 发表于 2014-7-17 19:19
你们程序无线调试变量,是怎么赋值的,???
是赋值给VAR1,VAR2等??
还是直接赋值给P D I 参数,, ...

不太理解,“,,(如电机反向1000减去转速,,最后变为10减)”是什么意思
回复 支持 反对

使用道具 举报

发表于 2014-7-22 17:37:28 | 显示全部楼层
你好!请问你们怎么融合各个功能模块的?我把它们放到一起,总有很多问题……
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部