注册 登录
查看: 452|回复: 11

[摄像头组] 鹰眼图像采集问题,不知是不是坏了【车子速度快了,发现图像会有一大片白的跳动】

[复制链接]
发表于 2014-7-13 00:06:47 | 显示全部楼层 |阅读模式

试车的时候发现鹰眼图像采集问题,不知是不是和采集速率有关?现象如下:

现象一:车子速度比较慢的话,整个赛道的图像都很清晰,但是提到一定速度后,过弯的时候就会有一大片白色的区域跳动。白色的区域是赛道外的(也可以理解为反光),这样一来就会导致车子找不到黑线,然后冲出赛道。
现象二:车子放在地上,通过调试器的液晶屏观察图像,发现当将摄像头猛地一抬起来时,整个赛道区域全部是白色的(只有非常细非常细的黑色的赛道边沿轮廓),静止2-3秒后,非跑道部分的白色会慢慢褪去,变成正常的黑色。

综合以上两个现象,我觉得有可能是鹰眼采集的速率反应不过来,也有可能是我们的鹰眼坏了(因为上次我们的鹰眼就已经坏了,引脚断开了,拿去外面让人帮焊上后,还是有两个引脚松动,现在我们是用热熔胶固定住的)。山外哥可以指点指点吗?快急死了,老是在一个固定的弯道那因为这个原因冲出赛道,其他一样的弯道都没有问题。导致现在速度一直上不去,唉,非常感谢山外哥之前的帮助

回复

使用道具 举报

 楼主| 发表于 2014-7-13 08:03:07 | 显示全部楼层
自顶一下。。。。
回复 支持 反对

使用道具 举报

发表于 2014-7-13 08:30:37 | 显示全部楼层
感觉这个和阈值有关,最近一直在手动修改鹰眼的阈值,不晓得最后情况,不好弄。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-7-13 12:54:15 | 显示全部楼层
.____. 发表于 2014-7-13 08:30
感觉这个和阈值有关,最近一直在手动修改鹰眼的阈值,不晓得最后情况,不好弄。

你调阈值了?效果好没
回复 支持 反对

使用道具 举报

发表于 2014-7-13 13:19:58 | 显示全部楼层
草原上的星星 发表于 2014-7-13 12:54
你调阈值了?效果好没

你试过调采集帧数没?
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-7-13 13:21:33 | 显示全部楼层
qq610061 发表于 2014-7-13 13:19
你试过调采集帧数没?

没试过,话说调那个会有什么效果?求指点
回复 支持 反对

使用道具 举报

发表于 2014-7-13 13:36:09 | 显示全部楼层
帧数就是在1秒钟时间里传输的图片的量,越高相当于采集的更快吧
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-7-13 13:55:57 | 显示全部楼层
qq610061 发表于 2014-7-13 13:36
帧数就是在1秒钟时间里传输的图片的量,越高相当于采集的更快吧

那默认是多少帧的?我们没有改过
回复 支持 反对

使用道具 举报

发表于 2014-7-13 16:58:49 | 显示全部楼层
首先,提高鹰眼的帧率,看看会不会改善。
因为车速度快了,曝光时间长,那么图像就会越模糊,就越不好二值化。

另外,调一下阈值,这个可以一定程度改善识别图像的。

将摄像头猛地一抬起来时,由于光照强弱变化太快,导致摄像头处于调整状态,图像效果大受影响。这个其他摄像头也会的,你可以用手机试试。
回复 支持 反对

使用道具 举报

发表于 2014-7-13 23:44:28 | 显示全部楼层
草原上的星星 发表于 2014-7-13 13:55
那默认是多少帧的?我们没有改过

默认多少我忘了  不过好像没有太高 还可以增加的
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-7-13 23:44:32 | 显示全部楼层
山外メ雲ジ 发表于 2014-7-13 16:58
首先,提高鹰眼的帧率,看看会不会改善。
因为车速度快了,曝光时间长,那么图像就会越模糊,就越不好二值 ...

鹰眼的帧率现在貌似是最高的了,150帧每秒。下午试着把阈值调为60,就好了好多,稳定多了
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-7-13 23:45:28 | 显示全部楼层
qq610061 发表于 2014-7-13 23:44
默认多少我忘了  不过好像没有太高 还可以增加的

我看了下程序,好像默认的就是150了,所以就不改了
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部