注册 登录
查看: 430|回复: 9

[K60] 山外哥,求救,头文件找不到

[复制链接]
发表于 2014-6-22 20:41:52 | 显示全部楼层 |阅读模式
Fatal Error[Pe1696]: cannot open source file "ARMCM4.h" C:\Users\Ace\Desktop\加入lcd 成功 重新换做自适应曝光\Lib\CMSIS\Inc\arm_math.h
怎么破

用的iar6.7
回复

使用道具 举报

发表于 2014-6-22 21:04:10 | 显示全部楼层
Lib\CMSIS\Inc\arm_math.h

看看这个头文件在不在,看看工程选项是不是没添加头文件所在路径
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-6-22 21:09:52 | 显示全部楼层
山外メ雲ジ 发表于 2014-6-22 21:04
Lib\CMSIS\Inc\arm_math.h

看看这个头文件在不在,看看工程选项是不是没添加头文件所在路径

这个解决了,但是ARMCM4.h这个找不到,好像是配置的底层库里的?
回复 支持 反对

使用道具 举报

发表于 2014-6-22 21:22:03 | 显示全部楼层
yoo 发表于 2014-6-22 21:09
这个解决了,但是ARMCM4.h这个找不到,好像是配置的底层库里的?

你是自己建工程吗?或者工程选项被破坏掉了?
要在工程选项里配置宏定义的。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-6-22 21:23:05 | 显示全部楼层
山外メ雲ジ 发表于 2014-6-22 21:22
你是自己建工程吗?或者工程选项被破坏掉了?
要在工程选项里配置宏定义的。

从别人那拷来的,怎么配置啊?
回复 支持 反对

使用道具 举报

发表于 2014-6-22 21:25:09 | 显示全部楼层
yoo 发表于 2014-6-22 21:23
从别人那拷来的,怎么配置啊?

别人把代码升级到高版本的IAR,然后你再用低版本的IAR打开,所以导致工程选项丢失。

从我们网盘下载吧
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-6-22 21:38:02 | 显示全部楼层
山外メ雲ジ 发表于 2014-6-22 21:25
别人把代码升级到高版本的IAR,然后你再用低版本的IAR打开,所以导致工程选项丢失。

从我们网盘下载吧

我是6.7的?
回复 支持 反对

使用道具 举报

发表于 2014-6-22 22:01:50 | 显示全部楼层
yoo 发表于 2014-6-22 21:38
我是6.7的?

这个你可以自己看IAR版本信息
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-6-22 22:08:10 | 显示全部楼层
山外メ雲ジ 发表于 2014-6-22 22:01
这个你可以自己看IAR版本信息

我用的是6.7版本,从网盘下的
回复 支持 反对

使用道具 举报

发表于 2014-6-22 22:13:35 | 显示全部楼层
yoo 发表于 2014-6-22 22:08
我用的是6.7版本,从网盘下的

如果别人拷贝给你前,用高于IAR6.7版本的打开过,那你用IAR6.7版本打开,也会出错
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部