注册 登录
查看: 435|回复: 9

[鹰眼] 冷火的鹰眼采集,图像抖动很厉害是怎么回事儿

[复制链接]
发表于 2014-5-6 15:35:22 | 显示全部楼层 |阅读模式
这段时间在搞图像处理,但是发现冷火采集回来的数据抖动非常大,经常出现“撕裂”的图像,请问该怎么解决?
回复

使用道具 举报

 楼主| 发表于 2014-5-6 15:38:27 | 显示全部楼层
自己做沙发,有知道的请指教一下,谢谢!
回复 支持 反对

使用道具 举报

发表于 2014-5-6 15:39:50 | 显示全部楼层
是不是图像受干扰了?下拉150欧电阻看看。
最好上传图片看看效果吧。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-5-6 19:13:07 | 显示全部楼层
锺离思涵 发表于 2014-5-6 15:39
是不是图像受干扰了?下拉150欧电阻看看。
最好上传图片看看效果吧。

是数据口下拉还是pclk和场中断呢?
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-5-6 19:13:58 | 显示全部楼层
锺离思涵 发表于 2014-5-6 15:39
是不是图像受干扰了?下拉150欧电阻看看。
最好上传图片看看效果吧。

就是受干扰了,摄像头的线不能长,长就出问题
回复 支持 反对

使用道具 举报

发表于 2014-5-6 22:04:31 | 显示全部楼层
山的那边有海 发表于 2014-5-6 19:13
就是受干扰了,摄像头的线不能长,长就出问题

pclk和场中断 下拉电阻150欧看看。
数据口一般比较稳定的,当然,可以下拉电阻来试试。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-5-7 13:17:43 | 显示全部楼层
山外メ雲ジ 发表于 2014-5-6 22:04
pclk和场中断 下拉电阻150欧看看。
数据口一般比较稳定的,当然,可以下拉电阻来试试。

现在发现是用灰排线,20cm的就会出现闪的问题,但是用20cm的杜邦线做成那种排线接上去,图像就不会闪了,但是杜邦线加长到40cm就又开始闪了。试了一下下拉电阻,场中断下拉150欧的信号就降太多了,只有0.5v左右,像素pclk加上下拉,信号没有变化,依旧有点像正弦波的样子。
回复 支持 反对

使用道具 举报

发表于 2014-5-7 13:34:36 | 显示全部楼层
山的那边有海 发表于 2014-5-7 13:17
现在发现是用灰排线,20cm的就会出现闪的问题,但是用20cm的杜邦线做成那种排线接上去,图像就不会闪了, ...

不会吧,我用软排线,都测得是方波。
你的时间轴调到 100ns 左右,调成触发模式捕捉,示波器看看效果。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-5-7 13:45:52 | 显示全部楼层
栾端静 发表于 2014-5-7 13:34
不会吧,我用软排线,都测得是方波。
你的时间轴调到 100ns 左右,调成触发模式捕捉,示波器看看效果。

场中断是方波,但是PCLK就是带很明显上升沿的那种凸起波形。
回复 支持 反对

使用道具 举报

发表于 2014-5-7 13:57:55 | 显示全部楼层
山的那边有海 发表于 2014-5-7 13:45
场中断是方波,但是PCLK就是带很明显上升沿的那种凸起波形。

来个图片吧,感觉是没测量好,测不好的时候是像正旋波的。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部