注册 登录
查看: 516|回复: 12

[鹰眼] 山外哥,SCCB读写错误,摄像头问题啊 不会又烧了吧。。这是第三个了。。

[复制链接]
发表于 2014-4-7 16:42:04 | 显示全部楼层 |阅读模式
山外哥,SCCB读写错误,摄像头问题啊 不会又烧了吧。。这是第三个了。。

淘宝那边说给换了一个芯片,测试图像闪动严重。。阀值没改 图像偏白;
使用调试版的测试hex没有问题,然后我们就是用山外哥的摄像头无线传输,接收端没图象,开始以为是
无线问题。。后让小车端运行调试模式 Call Stack 发现停留在SCCB delay函数下 串口打印出
“SCCB数据读写错误”。。


摄像头这次比赛进度彻底后退了。。。求山外哥助攻,,,

回复

使用道具 举报

 楼主| 发表于 2014-4-7 16:42:54 | 显示全部楼层
走过路过,不能错过
回复 支持 反对

使用道具 举报

发表于 2014-4-7 16:44:01 | 显示全部楼层
这么杯具啊。

鹰眼 拔掉其他线,然后 万用表打到 测通路那个档
红色表笔 接地 (上螺丝的那个地方就是地),黑色表笔接 SCL和SDA
看看读到值是多少
回复 支持 反对

使用道具 举报

发表于 2014-4-7 16:48:08 | 显示全部楼层
使用调试版的测试hex没有问题,然后用我们提供的其他例程就不行?
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-4-7 17:47:37 | 显示全部楼层
山外メ雲ジ 发表于 2014-4-7 16:48
使用调试版的测试hex没有问题,然后用我们提供的其他例程就不行?

山哥  们试了调试版的HEX  没有图像。。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-4-7 17:52:14 | 显示全部楼层
SunLei 发表于 2014-4-7 17:47
山哥  们试了调试版的HEX  没有图像。。

之前 客服邮过来说芯片问题 换了一个  这次下完原版程序就悲催了,,。,。,。  搞的现在摄像头程序都不敢改了,,  正值测试跑到的季节啊。。山哥有何良策?  望不惜赐教
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-4-7 17:54:20 | 显示全部楼层
山外メ雲ジ 发表于 2014-4-7 16:48
使用调试版的测试hex没有问题,然后用我们提供的其他例程就不行?

目前两个都不行了。。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-4-7 17:57:47 | 显示全部楼层
山外メ雲ジ 发表于 2014-4-7 16:44
这么杯具啊。

鹰眼 拔掉其他线,然后 万用表打到 测通路那个档

SDL == 1913  SCL  == 472
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-4-7 18:09:49 | 显示全部楼层
走过路过,不能错过  自定
回复 支持 反对

使用道具 举报

发表于 2014-4-7 18:13:13 | 显示全部楼层
SunLei 发表于 2014-4-7 17:57
SDL == 1913  SCL  == 472

奇怪了,这个问题,基本上都集中在几个客户的身上。
也有一个也修了3次的,你应该是第二个修了3次的。

这个SCL 和 SDA 管脚,你们再串接个510欧的电阻(限流),还有,不要带电插软排线(之前修了3次那个,他有两次是带电插软排线导致的。)

回复 支持 反对

使用道具 举报

发表于 2014-4-7 18:13:50 | 显示全部楼层
SunLei 发表于 2014-4-7 17:57
SDL == 1913  SCL  == 472

SDL 管脚是异常的,应该是烧了那个管脚了。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-4-7 18:29:58 | 显示全部楼层
山外メ雲ジ 发表于 2014-4-7 18:13
SDL 管脚是异常的,应该是烧了那个管脚了。

那该怎么办。。。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-4-7 18:32:55 | 显示全部楼层
山外メ雲ジ 发表于 2014-4-7 18:13
奇怪了,这个问题,基本上都集中在几个客户的身上。
也有一个也修了3次的,你应该是第二个修了3次的。
...

只能这样了 正给客服交流中  谢谢山哥
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部