注册 登录
查看: 501|回复: 13

[平衡组] 怪事啊!!!见鬼了,说好的反相器呢???????

[复制链接]
发表于 2014-3-25 19:07:35 | 显示全部楼层 |阅读模式
今天遇到各种怪事啊!!!要疯掉了!!!!山外哥的电机驱动说是放了反相器,所以80%占空比时,
应该是
FTM_PWM_Duty(FTM0, MOTOR1_PWM,1000-Speed);
FTM_PWM_Duty(FTM0, MOTOR2_PWM,1000);
Speed=800.
之前也是这样的没错,可是刚刚测速度时得到的结果却完全相反,说好的反相器呢????而且之前做好的函数Speed_L_Go(500)【左轮前进】现在变成后退了!!!!!
求救!!!!
回复

使用道具 举报

发表于 2014-3-25 20:41:10 | 显示全部楼层
之前是没错,但现在不行了? MOS管被击穿了?
回复 支持 反对

使用道具 举报

发表于 2014-3-25 20:41:35 | 显示全部楼层
我们是加了 MOS管隔离的,所以是产生反相的效果
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-3-25 20:44:15 | 显示全部楼层
山外メ雲ジ 发表于 2014-3-25 20:41
之前是没错,但现在不行了? MOS管被击穿了?

不知道啊,怎样才能知道MOS管有没有被击穿???我之前写的前进函数现在变成后退了,求解
回复 支持 反对

使用道具 举报

发表于 2014-3-25 20:51:55 | 显示全部楼层
草原上的星星 发表于 2014-3-25 20:44
不知道啊,怎样才能知道MOS管有没有被击穿???我之前写的前进函数现在变成后退了,求解

模块在你手上,你应该检测 输入和输出是否正确。

假如 MOS管真的被击穿,那就不要插着电机测,不然下次就击穿 单片机的了!然后换一个mos管。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-3-25 20:59:28 | 显示全部楼层
山外メ雲ジ 发表于 2014-3-25 20:51
模块在你手上,你应该检测 输入和输出是否正确。

假如 MOS管真的被击穿,那就不要插着电机测,不然下次 ...

输出除了刚刚说的那以外,没发现有什么异常啊,我刚刚查看了电机驱动,也没看出什么异常啊。不知问题出现在哪里
回复 支持 反对

使用道具 举报

发表于 2014-3-25 21:07:53 | 显示全部楼层
草原上的星星 发表于 2014-3-25 20:59
输出除了刚刚说的那以外,没发现有什么异常啊,我刚刚查看了电机驱动,也没看出什么异常啊。不知问题出现 ...

应该用示波器测啊!主动去找问题。
回复 支持 反对

使用道具 举报

发表于 2014-3-26 01:20:24 | 显示全部楼层
这个硬件是硬件问题,好好检测硬件电路吧
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-3-26 13:36:42 | 显示全部楼层
阙云亭 发表于 2014-3-26 01:20
这个硬件是硬件问题,好好检测硬件电路吧

唉,我也想的啊,只是我们的条件实在是。。。。。。。唉,要工具没工具,要地方没地方。说多了都是泪啊
回复 支持 反对

使用道具 举报

发表于 2014-3-26 14:04:33 | 显示全部楼层
草原上的星星 发表于 2014-3-26 13:36
唉,我也想的啊,只是我们的条件实在是。。。。。。。唉,要工具没工具,要地方没地方。说多了都是泪啊

搞这些没工具,怎么搞啊?应该可以问学校老师借的吧?
我们队的都是问隔壁研究生师兄那里借的
回复 支持 反对

使用道具 举报

发表于 2014-7-2 20:14:23 | 显示全部楼层
走过路过,不能错过
回复 支持 反对

使用道具 举报

发表于 2014-11-19 12:57:35 | 显示全部楼层
111xian 发表于 2014-7-2 20:14
走过路过,不能错过

好专业的回复!
都醉了
回复 支持 反对

使用道具 举报

发表于 2014-11-19 13:01:03 | 显示全部楼层
草原上的星星 发表于 2014-3-26 13:36
唉,我也想的啊,只是我们的条件实在是。。。。。。。唉,要工具没工具,要地方没地方。说多了都是泪啊

这么惨?
那还真是说多了都是泪
回复 支持 反对

使用道具 举报

发表于 2014-11-19 15:58:05 | 显示全部楼层
感觉很高端的样子,嘻嘻
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部