注册 登录
查看: 706|回复: 7

[K60] 新的单片机,下载程序没问题,LED也亮,可是。。

[复制链接]
发表于 2013-6-5 19:06:51 | 显示全部楼层 |阅读模式
买回来的初始程序是led闪烁没问题,下载程序也没问题,LED电源指示灯也好着,可是。。下午刚拿到的两个单片机。。一个好的,另外一个不行。。。。。。。。一样的程序,一样的电路,好的那个单片机和另外一个旧的单片机就能用,那个坏的led灯能亮可是其他模块不运行。。哪儿坏了我也不知道,但是程序不运行。。最起码电机没转
单片机电源也都正常,没有烧也没有短路啥的。这是什么原因的?客服说可能锁了??unlock kinetis也没用啊。。@fire  求救

回复

使用道具 举报

 楼主| 发表于 2013-6-5 19:07:50 | 显示全部楼层
控制变量都试过了,电源什么都没问题,,其他两个单片机就可以,这个不行
回复 支持 反对

使用道具 举报

发表于 2013-6-5 19:44:40 | 显示全部楼层
本帖最后由 山外メ雲ジ 于 2013-6-5 19:47 编辑

没看明白你的意思。

不行的那个,能不能下载程序?
烧写LED 例程能不能出现流水灯?

如果不能下载程序,提示什么信息?
回复 支持 反对

使用道具 举报

发表于 2013-6-5 19:49:28 | 显示全部楼层
我们的 核心板,全部都测试过 串口 、 无线模块 、摄像头模块 、液晶显示模块的,你可以看到我们有专门的测试例程,不像其他人那样只测试 LED
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-6-6 17:18:32 | 显示全部楼层
山外メ雲ジ 发表于 2013-6-5 19:49
我们的 核心板,全部都测试过 串口 、 无线模块 、摄像头模块 、液晶显示模块的,你可以看到我们有专门的测 ...

测试了led和PWm都没问题,给定PWM轮子也可以转,可是,可是下载上程序就不行了,完全一样的程序,完全一样的硬件,用其他两个单片机车子就可以跑,这个轮子连动都不动
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-6-6 18:08:47 | 显示全部楼层
@山外メ雲ジ
回复 支持 反对

使用道具 举报

发表于 2013-6-7 07:53:45 | 显示全部楼层
我爱小kb 发表于 2013-6-6 17:18
测试了led和PWm都没问题,给定PWM轮子也可以转,可是,可是下载上程序就不行了,完全一样的程序,完全一样 ...

k60芯片,在你看来是一样的型号,实际上他们的性能也不一定是相同的,就简单的超频,有些可以超到 250M,大部分都可以超到200M ,芯片是有差异的。

驱动能力也是有差异的,你首先用示波器测试一下pwm是否有输出,如果有 pwm 输出,是证明芯片是没问题的。

哪怕其他两片可以运行,只能说那是不稳定的可行。
回复 支持 反对

使用道具 举报

发表于 2013-6-7 07:56:12 | 显示全部楼层
我爱小kb 发表于 2013-6-6 17:18
测试了led和PWm都没问题,给定PWM轮子也可以转,可是,可是下载上程序就不行了,完全一样的程序,完全一样 ...

例如我之前帮一个同学调 LCD ,他就是说 一块 核心板 行,一块核心板不行  ,代码相同,核心板也相同,最后发现他的时序太快,我在中间加入延时后,两块 核心板 都可以正常 了
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部