注册 登录
查看: 630|回复: 7

鹰眼,SDA总线错误(急)

[复制链接]
发表于 2013-5-26 18:39:15 | 显示全部楼层 |阅读模式
上一次买的开发板的鹰眼是没有问题的,烧上例程,可以显示图像头的。但是这次新买的鹰眼用在开发板上一直显示不了图像,后来用同样的程序调试,一直没有办法成功配置,程序在后面注释有SDA总线错误的地方跑,请问是不是摄像头的问题啊?求解答,谢谢
回复

使用道具 举报

 楼主| 发表于 2013-5-26 19:33:53 | 显示全部楼层
同样是跑到这里跑不过去了
while( 0 == SCCB_WriteByte ( 0x12, 0x80 ) ) /*复位sensor */
    {
        i++;
                if(i == 20)
                {
                        DEBUG_OUT("警告:SCCB写数据错误");
                        //OV7725_Delay_ms(50);
                        return 0 ;
                }
               
    }
回复 支持 反对

使用道具 举报

发表于 2013-5-27 08:33:55 | 显示全部楼层
你好啊,由于sccb是软件模拟,所以不太稳定。
请用我附件里的代码替换一下试试:


直接替换工程原文件即可

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-5-27 22:10:30 | 显示全部楼层
山外メ雲ジ 发表于 2013-5-27 08:33
你好啊,由于sccb是软件模拟,所以不太稳定。
请用我附件里的代码替换一下试试:

恩,好的,谢谢了。
再问一下在,例程里的鹰眼初始化配置之后能不能输出的行中断的,我用示波器看了一下,输出幅值连1V都不到,这是怎么回事?
回复 支持 反对

使用道具 举报

发表于 2013-5-28 07:52:12 | 显示全部楼层
我是大宣 发表于 2013-5-27 22:10
恩,好的,谢谢了。
再问一下在,例程里的鹰眼初始化配置之后能不能输出的行中断的,我用示波器看了一下 ...

鹰眼是靠 上升沿触发,信号不太标准,所以 K60 才能用,xs128很难用的
回复 支持 反对

使用道具 举报

发表于 2013-5-28 14:47:57 | 显示全部楼层
我是大宣 发表于 2013-5-27 22:10
恩,好的,谢谢了。
再问一下在,例程里的鹰眼初始化配置之后能不能输出的行中断的,我用示波器看了一下 ...

我的也是这个问题,你的这样可以吗?
回复 支持 反对

使用道具 举报

发表于 2013-5-28 15:12:31 | 显示全部楼层
山外メ雲ジ 发表于 2013-5-27 08:33
你好啊,由于sccb是软件模拟,所以不太稳定。
请用我附件里的代码替换一下试试:

我跟楼主一模一样的问题,程序卡在了whlie循环里面了,试了你的附件还是一样的问题
回复 支持 反对

使用道具 举报

发表于 2013-5-28 15:52:21 | 显示全部楼层
zswxzl 发表于 2013-5-28 15:12
我跟楼主一模一样的问题,程序卡在了whlie循环里面了,试了你的附件还是一样的问题

那应该是管脚没连接好吧,直接插到小霸王调试板上看看
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部