注册 登录
查看: 437|回复: 8

[K60] 山外哥,我用ad模块读取陀螺仪输出电压时出现问题了

[复制链接]
发表于 2014-1-5 12:23:59 | 显示全部楼层 |阅读模式
这是我写的电压ad转换程序,添加有虚拟示波器串口输出。
void main()
{
    uint16 var;
    adc_init(ADC1_SE8);              //ADC初始化

    while(1)
    {
        var = adc_once   (ADC1_SE8, ADC_12bit);
                sbq(var,0,0,0);//示波器发送程序

        DELAY_MS(5);

    }
}
烧写k60 FX芯片出现问题了,示波器显示出来的图像特别乱。
我用k60 DN芯片时,示波器显示很正常。
下边是具体的示波器图像

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复

使用道具 举报

 楼主| 发表于 2014-1-5 12:29:55 | 显示全部楼层
我调了一上午,用k60 DN很正常,当用k60 FX就出问题了。我都快哭了。
在调k60 FX时我试过把B0接地和接3.3v,示波器输出来的图像还算正常。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-1-5 12:39:19 | 显示全部楼层
山外哥我已经测出来问题了,是板子的问题。我用实验室的另一块k60 FX开发板测试了,图像很正常。
回复 支持 反对

使用道具 举报

发表于 2014-1-5 13:11:13 | 显示全部楼层
JIE 发表于 2014-1-5 12:39
山外哥我已经测出来问题了,是板子的问题。我用实验室的另一块k60 FX开发板测试了,图像很正常。

不好意思,可能测试 的 时候 没测出来,联系 客服 换 一个吧,非常抱歉
回复 支持 反对

使用道具 举报

发表于 2014-1-5 13:19:44 | 显示全部楼层
应该是 参考电压 跟 3.3V 之间 的 0欧 电阻 虚焊了 ,你 可以尝试短接 一下  REF 和 3V3 (在 无线模块 接口 旁边 )
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-1-5 14:37:54 | 显示全部楼层
山外メ雲ジ 发表于 2014-1-5 13:19
应该是 参考电压 跟 3.3V 之间 的 0欧 电阻 虚焊了 ,你 可以尝试短接 一下  REF 和 3V3 (在 无线模块 接口 ...

谢谢山外哥了,核心板好像没插紧。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-1-5 14:38:43 | 显示全部楼层
山外メ雲ジ 发表于 2014-1-5 13:19
应该是 参考电压 跟 3.3V 之间 的 0欧 电阻 虚焊了 ,你 可以尝试短接 一下  REF 和 3V3 (在 无线模块 接口 ...

谢谢山外哥了,核心板与板子有点接触不良
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-1-5 14:39:07 | 显示全部楼层
山外メ雲ジ 发表于 2014-1-5 13:19
应该是 参考电压 跟 3.3V 之间 的 0欧 电阻 虚焊了 ,你 可以尝试短接 一下  REF 和 3V3 (在 无线模块 接口 ...

谢谢山外哥了,核心板与板子有点接触不良
回复 支持 反对

使用道具 举报

发表于 2014-1-5 15:49:47 | 显示全部楼层
JIE 发表于 2014-1-5 14:39
谢谢山外哥了,核心板与板子有点接触不良

嗯嗯,我们应该做的
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部