注册 登录
查看: 698|回复: 16

串口实验的问题

[复制链接]
发表于 2013-12-15 22:27:14 | 显示全部楼层 |阅读模式
山外哥做串口实验时是要给开发板插上5V供电、串口线、还有Jlink吗?USB转串口线不是可以下载程序么?为什么还要连接Jlink。
我做串口实验时给开发板插上5V供电、连接串口线、还有Jlink,剩下的步骤都是按照教程做的,实验总是失败,像下图所示:
还有超级终端的那个窗口是从哪里打开的?
[img]file:///C:\Users\chenjianwei\AppData\Roaming\Tencent\Users\849928055\QQ\WinTemp\RichOle\YN2DT$9F17%$%N`~0_FP`[J.jpg[/img]

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复

使用道具 举报

发表于 2013-12-15 23:00:27 | 显示全部楼层
boot 开关是否 选择 对了?
串口下载 不需要 接 jlink ,但需要 boot 开关 改一下
回复 支持 反对

使用道具 举报

发表于 2013-12-16 04:17:35 | 显示全部楼层
有竞争才有进步嘛
回复 支持 反对

使用道具 举报

发表于 2013-12-16 08:35:52 | 显示全部楼层
Jlink可以下载程序和在线仿真。使用串口下载时需要将BOOT0接高电平,下载之后接低电平,在山外哥的板子上就是拨动一个拨动开关。
串口实验室要接九针的串口线的。还有就是可以使用串口助手开进行串口实验,不一定要使用超级终端。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-12-16 09:29:56 | 显示全部楼层
boot 开关选对了,今天回家再试试看
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-12-16 21:36:16 | 显示全部楼层
Admin 发表于 2013-12-15 23:00
boot 开关是否 选择 对了?
串口下载 不需要 接 jlink ,但需要 boot 开关 改一下

山外哥我按照我们那教程上做了,boot0拨到VCC时如图所示:
然后把boot0拨到GND,点击“开始编程”后:
然后再按复位键后显示:
和我们教程上的结果不一样是怎么回事呀?我不知道那个地方搞错了?

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
回复 支持 反对

使用道具 举报

发表于 2013-12-16 22:58:06 | 显示全部楼层
7318 发表于 2013-12-16 21:36
山外哥我按照我们那教程上做了,boot0拨到VCC时如图所示:
然后把boot0拨到GND,点击“开始编程”后:
然 ...

你的 第一个 图片 已经 正常下载啦,报告 正常了。
下载完成后,需要 把 boot 接 低电平 才能正常运行。(否则进入 ISP 状态,不会运行程序)
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-12-17 08:54:10 | 显示全部楼层
Admin 发表于 2013-12-16 22:58
你的 第一个 图片 已经 正常下载啦,报告 正常了。
下载完成后,需要 把 boot 接 低电平 才能正常运行。 ...

下载完成后我把boot接低电平了,然后的结果就是后两个图了
回复 支持 反对

使用道具 举报

发表于 2013-12-17 09:45:34 | 显示全部楼层
7318 发表于 2013-12-17 08:54
下载完成后我把boot接低电平了,然后的结果就是后两个图了

boot 打到 低电平,是 不能 用来 下载 ISP 的!!

仅仅是 用来 启动 程序。

你把 boot 达到 高电平,然后 下载 ,下载后 接 回 低电平。如果需要下载,那么重新打到 高电平 下载
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-12-17 21:07:34 | 显示全部楼层
Admin 发表于 2013-12-17 09:45
boot 打到 低电平,是 不能 用来 下载 ISP 的!!

仅仅是 用来 启动 程序。

山外哥我就是把 boot 打到 高电平,然后下载 ,下载后接回低电平,可是不管是开发板还是mcuispV0.993窗口都没实验现象,而且我开发板上的液晶屏也不亮的。正常情况下串口打印出来的信息是显示在mcuispV0.993窗口的不。
郁闷呢?不知道哪一步搞错了。。。
回复 支持 反对

使用道具 举报

发表于 2013-12-17 21:39:01 | 显示全部楼层
7318 发表于 2013-12-17 21:07
山外哥我就是把 boot 打到 高电平,然后下载 ,下载后接回低电平,可是不管是开发板还是mcuispV0.993窗口都 ...

把 boot 打到 高电平,然后下载 ,下载后接回低电平

然后 复位试试……
回复 支持 反对

使用道具 举报

发表于 2013-12-17 21:42:41 | 显示全部楼层
7318 发表于 2013-12-17 21:07
山外哥我就是把 boot 打到 高电平,然后下载 ,下载后接回低电平,可是不管是开发板还是mcuispV0.993窗口都 ...

把 boot 打到 高电平,然后下载 ,下载后接回低电平

然后 复位试试……
回复 支持 反对

使用道具 举报

发表于 2013-12-17 22:06:18 | 显示全部楼层
7318 发表于 2013-12-17 21:07
山外哥我就是把 boot 打到 高电平,然后下载 ,下载后接回低电平,可是不管是开发板还是mcuispV0.993窗口都 ...

波特率 调到 9600 ,步骤应该没错的
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-12-18 09:23:57 | 显示全部楼层
Admin 发表于 2013-12-17 22:06
波特率 调到 9600 ,步骤应该没错的

我换了个串口调试助手后让我弄好了,我们那个光盘里带的串口调试助手我没用好,16进制显示的都是数字字母的,昨晚我自己弄好了,心情刷得变好了,山外哥这几天麻烦你了,谢谢啊
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-12-18 09:24:57 | 显示全部楼层
风落小鱼 发表于 2013-12-17 21:42
把 boot 打到 高电平,然后下载 ,下载后接回低电平

然后 复位试试……

谢谢了朋友,串口昨晚我自己给搞好了
回复 支持 反对

使用道具 举报

发表于 2013-12-18 09:31:36 | 显示全部楼层
7318 发表于 2013-12-18 09:23
我换了个串口调试助手后让我弄好了,我们那个光盘里带的串口调试助手我没用好,16进制显示的都是数字字母的 ...

我也还一直担心是板子的问题,经过一番折腾,解决问题的能力是不是又提高了。
ps:有一些人,遇到你这种情况,打死都是坚持是板子的问题,要寄回来保修的,来回邮费还要我们出,
    这种人真是杠杠滴啊
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-12-18 09:48:11 | 显示全部楼层
Admin 发表于 2013-12-18 09:31
我也还一直担心是板子的问题,经过一番折腾,解决问题的能力是不是又提高了。
ps:有一些人,遇到你这种 ...

我没有感觉板子有问题的,一开始我就感觉自己哪个地方没操作对,毕竟刚毕业,51单片机也没怎么玩过,刚才加工作,公司用的STM32来发的老板让我抓紧学让写程序呢,所以有好多不懂的,所以最近一直请教呢?不过话说回来搞电子方面的问题确实会出现好多莫名的问题,我觉得出现还得自己先找找,不会的问问人不是.
经过这一番折腾解决问题的能力确实提高了,知道出了问题向多个方向想想,不会死脑筋认为是哪一个问题.
山外哥你是挺耐心的,真心的感谢你,祝山外哥的生意兴隆,越办越好...
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回列表 返回顶部